How to upgrade SVN Client on CentOS/RHEL 5/6/7

Share It!

If you get the error like “This client is too old to work with working copy” when you use svn client,it means you need a newer svn client.


This tutorial will help you to install Subversion 1.7 on CentOS.

Import Key:

Import RPM signing key for verifying packages using following command.

# rpm --import

Install RPMForge Repository

Install RPMForge repository by selecting appropriate rpm package for your system.
For CentOS/RHEL 7 64 Bit:

# rpm -Uvh

For CentOS/RHEL 6 32-64 Bit

CentOS/RHEL 6 32 Bit
# rpm -Uvh
RHEL/CentOS 6 64 Bit
# rpm -Uvh

For CentOS/RHEL 5 32-64 Bit

CentOS/RHEL 5 32 Bit
# rpm -Uvh
RHEL/CentOS 5 64 Bit
# rpm -Uvh

Check RPMForge Repository:

We can check repository using following command:

# yum repolist

Install Subversion:

After installing RPMForge repository now install subversion using following command.

# yum install --enablerepo=rpmforge,rpmforge-extras subversion

Leave a Reply

Your email address will not be published.